Topic: Problema importazione Moduli aggiuntivi con PIP  (Letto 173 volte)

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline davrigo

  • python unicellularis
  • *
  • Post: 1
  • Punti reputazione: 0
    • Mostra profilo
Problema importazione Moduli aggiuntivi con PIP
« il: Maggio 28, 2018, 10:11 »
Buongiorno a tutti, premetto che sono un principiante e da poco mi sto cimentando con questo linguaggio. Utilizzo Python 3.6 con Pycharm e avre la necessità di installare moduli aggiuntivi. Ho provato a seguire alcune indicazioni online ma nulla, l'installazione non va a buon fine.. Dal prompt dei comandi vado della cartella script di python dove risiede il file pip.exe eed eseguo il comando PIP INSTALL TELEPOT (per importare modulo per telegram) e mi compare questa scritta:


C:UserScripts>pip install telepot
Requirement already satisfied: telepot in c:userlibsite-packages
Requirement already satisfied: urllib3>=1.9.1 in c:userlibsite-packages (from
 telepot)
Requirement already satisfied: aiohttp>=3.0.0 in c:userlibsite-packages (from
 telepot)
Requirement already satisfied: multidict<5.0,>=4.0 in c:userlibsite-packages
(from aiohttp>=3.0.0->telepot)
Requirement already satisfied: async-timeout<4.0,>=3.0 in c:userlibsite-packa
ges (from aiohttp>=3.0.0->telepot)
Requirement already satisfied: yarl<2.0,>=1.0 in c:userlibsite-packages (from
 aiohttp>=3.0.0->telepot)
Requirement already satisfied: idna-ssl>=1.0 in c:userlibsite-packages (from
aiohttp>=3.0.0->telepot)
Requirement already satisfied: attrs>=17.3.0 in c:userlibsite-packages (from
aiohttp>=3.0.0->telepot)
Requirement already satisfied: chardet<4.0,>=2.0 in c:userlibsite-packages (f
rom aiohttp>=3.0.0->telepot)
Requirement already satisfied: idna>=2.0 in c:userlibsite-packages (from yarl
<2.0,>=1.0->aiohttp>=3.0.0->telepot)
You are using pip version 9.0.1, however version 10.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' comm
and.

C:UserScripts>


Mi sapete dire cosa e dove sbaglio.

Grazie

Offline Giornale di Sistema

  • python sapiens sapiens
  • ******
  • Post: 3.124
  • Punti reputazione: 4
    • Mostra profilo
    • Distillato di Python
Re:Problema importazione Moduli aggiuntivi con PIP
« Risposta #1 il: Maggio 28, 2018, 12:07 »
Dal prompt dei comandi vado della cartella script di python dove risiede il file pip.exe eed eseguo il comando PIP INSTALL TELEPOT (per importare modulo per telegram) e mi compare questa scritta:
Requirement already satisfied: telepot in c:userlibsite-packages


Quelle "scritte" sono il log delle operazioni che pip sta facendo e come sta andando: non ti sta dicendo che sbagli qualcosa, ti sta dicendo invece  una ad una tutte le dipendenze che prova ad installare perché necessarie all'installazione di Telepot, ma che trova già soddisfatte (ossia già installate), Telepot compreso che è la prima riga del log che ti ho evidenziato.

Quindi è tutto a posto, per averne conferma prova ad usarlo e saprai con certezza se è così.

Poi visto che c'è, pip ti dice anche che stai usando una sua vecchia versione e ti suggerisce come aggiornarlo:
You are using pip version 9.0.1, however version 10.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.


P.S. se puoi scegli con più attenzione la sezione del forum in cui posti le domande, qui si discorre di problemi di passaggio da Python 2.x a Python 3.x.
« Ultima modifica: Maggio 28, 2018, 12:10 da Giornale di Sistema »

Offline RicPol

  • python sapiens sapiens
  • ******
  • Post: 2.821
  • Punti reputazione: 9
    • Mostra profilo
Re:Problema importazione Moduli aggiuntivi con PIP
« Risposta #2 il: Maggio 28, 2018, 14:29 »
... e già che ci siamo, prenditi un po' di tempo per leggere la mia guida (link in firma)  che ti spiega come fare le cose per bene...